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Overview

This document is provided as a first step in learning how to use
PathMATE with the Topcased Modeler environment to build platform
independent models and transform them to an executable system.
The instructions in this guide are detailed with screen shots and other
aids to keep you moving forward quickly.

The Platform Independent MDD (PI-MDD) approach for building
systems and the PathMATE environment for automating this approach
are specifically intended to address the key challenges faced when
building complex, high-performance systems. Unfortunately we
cannot have you quickly build a highly complex system that shows off
all of PathMATE'’s capabilities — at least not as your first step. Instead
we will start you with SimpleOven. This is a very simple example
system that covers some of the key elements of a PathMATE system.
The goal of this Quick Start Guide is to expose you to some of the core
aspects of modeling, code generation, system construction and
execution as quickly as possible. After completing this Guide please
explore the more sophisticated example systems provided with
PathMATE, such as ExperimentControl, to gain a more complete
understanding of how real-world systems are constructed.

How to Use this Guide

If you are not yet familiar with the PathMATE toolset, please continue
to read this Overview section.

If you have not installed the PathMATE toolset on your computer,
follow the Download PathMATE section to download the software from
the PathTECH portal at www.pathfindermda.com.

Continue to learn how PathMATE works by completing the walk-though
tutorial beginning with the “"Model a Simple Oven” section.

Whether you have created hundreds of models and systems or none at
all, you can follow this tutorial. Learn quickly how to use PathMATE to
develop an executable system.

Audience

The Quick Start Guide is for software modelers who want to learn how
to design high performance and embedded systems with PathMATE.
It's helpful but not essential to have some familiarity with the
Topcased Modeler toolset.

Additional Resources

The Pathfinder Solutions website at www.pathfindermda.com offers
information on products, services, and model-driven approaches and
technology. After completing this walkthrough tutorial, you'll want to
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explore the extensive collection of whitepapers available as PDF
downloads. Direct email support is available from
support@pathfindermda.com.

Eclipse

Eclipse is supported by an international open source effort and is freely
downloaded by thousands of professionals. PathMATE provides feature
plugins to Eclipse which extend its functionality using the framework
as a basis for interoperability. For further information on Eclipse, go to
www.eclipse.org. This tutorial will often refer to common framework
elements reflecting this heritage; e.g., “Eclipse Menu” or “Eclipse
Toolbar”. The tutorial assumes that you are familiar with basic Eclipse
terminology including the specialized terms, “View”, “Editor”,
“Perspective”, and “Navigator”.

Conventions
The Quick Start Guide uses these conventions:

e Bold is for clickable buttons and menu selections.

e Italics is for screen text, path and file names, and other text that
needs special emphasis.

e Courier denotes code, or text in a log or a batch file.
e A Note contains important information, or a timesaving tip.

o__. ¢ The scissors icon marks text that you copy from this document
<N
and paste elsewhere.

What You’'ll Need

To complete the steps in this guide, you'll need the following software
on your computer:

e PathMATE for Topcased software development toolkit

¢ Windows

= Microsoft Windows 2000 or Windows XP Professional Edition or
Windows Vista

=  Microsoft Visual C++ version 6+
e Linux
= Make and a C, CPP, or JAVA compiler
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PathMATE PI-MDD Toolset

Through its Architectural Focus and advanced automation, PathMATE is
the leading MDD environment for embedded, real-time systems
development. This powerful technology automates the verification,
execution and deployment of Platform-Independent MDD models and
automatically transforms them into high performance C, C++, and
Java systems that are specifically optimized for resource-constrained
embedded environments. Over years of rigorous refinement in several
industries, PathMATE tools have proven their value in rapid and
effective embedded systems development.

The PathMATE Model Automation and Transformation Environment
includes all the tools required to transform your models into high-
performance embedded systems:

1.1 T

viogdel vrrven Arciiitec

PathMATE Mode! Automation and Transformation Eﬂﬁffdr_@l

Application-Specific L
Requirements Hatform-Spanfic PathMATE™

Requirements Transformation Maps

Con'e
Tsmp.l'ams

PathMATE e
Transformauon

Your Favorite UML Editor
customized for MDA™ modeling

Non-
Modeled
Elements

PathMATE™
Spotlight

 Pathfinder Solution.
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The PathMATE PI-MDD Toolset is comprised of three parts which work
together to turn your models into executable embedded systems:

e Transformation Engine — generates embedded software
applications from your application-specific platform-independent
models.

e Transformation Maps - guide the conversion process from model
to platform-specific executable code. You can choose from
standard off-the-shelf C, C++, and Java maps. To meet the
demands for other languages or specific platform needs, our
consultants can work with you to develop customized high-
performance maps.

e Spotlight — provides the most advanced model testing
environment available to verify and debug your application logic.

No other MDD transformation environment offers a more open or
configurable set of development tools, designed to meet the
requirements of embedded systems engineers.
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Download and Install PathMATE

1. Navigate to http://www.pathfindermda.com. The Pathfinder
Solutions home page opens.
2. Log into PathTECH at the top of the main web page with user

ID demo. Please contact your account manager to obtain your
password.

Pathfinder
~ Solutions

PathTECH Login - User (0 | P

Site Map | Cantact Us

On the PathTECH download page you’'ll be able to select the
appropriate PathMATE product downloads:

(_.;'www.PathfinderMDA.com - Windows Internet EHD'DI‘:_ 10l x|
@:—-: - |g http:f,l’www.pathFindermda.com,l’pathtech,l’inj 4| X IGoogIe 2=
J File Edit Wew Favorites Tools Help

J GDUglC||C|v jGo +® ﬁ - | % Eookmarks» @8? blocked > Settingsv

12? ke @ www, PathfinderMDA, com

J @ -’ - E@ ~ |:2fPage - "__f._‘;}Tgols - F
g Pathfinder NG
™ Solutions

To download PathMATE product component installer files, click on the installers listed below.
Download installation instructions here. Then execute the downloaded self-extracting files to install.
Answers to some of our more common questions are here.

Fleaze note: the PathMATE Environment is required to be installed before any other PathMATE
components are installed.

PathMATE Resources

Install Instructions

Product Documentation
Frequently Azked Questions
Quick Start Guide for RSK

Quick Start Guide for Rose

Quick Start Guide for Rhapsody

PathMATE Product Installer Downloads

PathMATE version 7.4.0 (for all editors)

PathMATE version 7.4.0 for Rational Software Modeler version 7.0.5

4 |
CT T T e

5

H100% v g

| (2. Error on page.
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3. Download the following files:

e PathMATE, version 8.0.0 (for all editors), for
the correct operating system.

e PathMATE Transformation Map for Java, version
8.00.000 (if you will be generating Java
implementation code.)

e Installation Instructions — Follow these
instructions to install the product and secure a
key file.

After installation, see the file C:/PathMATE/doc/PathMATE_with_Visual_
Studio_Express.pdf for specific instructions on how use Microsoft Visual
Studio 2005 Express Edition if you plan to use this environment.

Eclipse and Topcased

The PathMATE version 8.0 (for all editors) installation includes a free

preconfigured distribution of Eclipse v3.4 with Topcased 2.3 already
configured.
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Create a Platform Independent Model for
SimpleOven

Eclipse Workspaces

When you launch Eclipse, designate a workspace to store all the files
for the sample system. Typically you designate your workspace once,
just after you install Eclipse. We refer to this directory as your
Workspace Directory. Use the same workspace whenever you work on
this tutorial.

To work with PathMATE, activate the Eclipse “Topcased” Perspective.
This is done in the Eclipse Window Menu under Open Perspective,
select other. When the dialog opens find and choose Topcased
Modeling Perspective.

As with most leading software products, there are generally many
ways in which a given action can be performed. We present a single,
simple, and consistent way for maximum clarity. As you gain
experience and comfort, explore the menus and dialogues. Try out
some of the alternatives and develop the work style most comfortable
to you.

Task 1: Create a PathMATE UML Project Using the
PathMATE Project Template

PROCEDURE: Use PathMATE New Project Wizard in Eclipse
1. Launch Eclipse from the Windows Start->All Programs menu
with Pathfinder Solutions > Eclipse:

ﬁ Pathfinder Solutions » .lj Rose Carshuffle r
Jﬂ Rose Robochef k
.lj Rose SimpleCryen r
CrE——
“ 4§ Installation Manager
[N spotiight

2. Ifitis not already selected, select the Topcased Modeling
perspective: click on the Open Perspective button ...

Modeling "5 Resource
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3.

...click Other to get the complete set of perspectives, and select

the Topcased Modeling perspective:

£ Open Perspectiv

=10 x|

é':' Team Synchronizing
i Topcased Modeling

o]

B
-]

Cancel |

Click OK.

In Eclipse, select Window > Preferences and navigate to

Topcased > Editor. Note what the default unit is (and if
options are available change to unit of choice).

Now Navigate to Topcased > Editors > Page Format.

Click Add and name your new format HalfPageFormat. Select
Landscape Default Orientation, enter 800 for the Page width,
and 594 for the Page height. Select HalfPageFormat and press

&= Preferences

|tw:ue filber bext

- Model Validation

- PathMATE

- Plug-in Development

T

+- RunyDebug

-- Tasks

-- Team

- Topcased

(1 Editars
Page Format
+Page Margins
- 58M
[ SysML
- LML

- Log4i

- Projet ko Template

-~ 55H Connection
- \Web Server

[+ UMLZ Diagrarns

[+ Usage Data Collector

l |

- S5AM Reguirements - AEE

Default.
_|ol x|
Page Format - T
LI —Page Farmat
Available page Format ¢ [as Add

A4

A3 Remove

Az

HalfFageFaormat (default)

Default

i

Marne : | HalfPageFormat

|Z—+

Page width : I 7.5 ‘

T Page height : |5

— Orientation
Default orienkation : ¢ Porkrait

¥ Landscape

-

Cl

Restore Defaults |

{ 'I_? 1

(04 | Cancel

8. Click Apply and OK.
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9. In Eclipse, select File > New, pick the PathMATE for Topcased
Project Generator wizard and click Next:

£ Mew Project - O] x|

Select a wizard

Wizards:
fPath B

= [E'; PathMATE For Topcased

""" & ¥rathmate for Toprased Project Generator

(7) = Back I Mext = I Einish | Cancel |

The UML Modeling Project wizard opens:

~1o| x|

Pathmate for Topcased Project

Creakte a new project resource,

Project marme: | QuickStartl

¥ Use default location

Location; I a7 _workd QuickStark Browse, .. |

Chonse File systenm: Idefault j

(7) < Back. I Mexk = I Finish Cancel
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10. Type QuickStart in the Project name field and click Next.

The Create Model dialog opens:

=10l x|
PathMATE for Topcased Project

Create a new model resource,

Eile name: | Quickstart System Model, uml

i+ New Swskem ™ New Domain

(7) < Back. | Mexk = | Firish I Cancel

11. Select the New System button, in the File name field replace
"new" with "QuickStart System Model", and click Finish.
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The QuickStart Project appears in the Topcased Navigator, and the

contents of the Quick Start System Model are shown in the Outline
View:

& Topcased Modeling - QuickStart /Models/QuickStart System Model.umidi - Eclipse Platform

z _loix|
Fie Edt Havigate Search Project SmartQVT Run Window Help

|es-Gl@ala- |- a2 ¢ -0 o - [ O Rl | R S| e AT ¥ 5| € Topcasedmo... [ Modeling
5 Navigator | € Topcased Naviga 32 T O || % Quickstart System Model.umidi I3
o b v | fQuidStanodetsiQuikstart System Model.unid

T e [ Seect package SystermMadel =
[=-(= Models

+ [} Marquee
) Quickstart System Madel.uml
i .

=0

, Mote
- by QuickStart System Modsl,umidi
| Diagram ha name (= Objects )
; " Diagram System Domain Diagram o Package
(= PathMATE
= Class

P o File/Model Viewer

4 Operation
[ Property

(=) Instance Specification

Topcased Navigator | === -

v/ hssociation
£ Association Class
./ Inskance Specification link
A Generalization

4 Intesface Realization

4] 2|+ . Dependency
8% outline = 0| ®] Package Import
At m 2~
Zls = (= Comment =

[=) Comment
<<tlass, housekesping>>» <Class» Sys

<Package® System Types
<Prafile Application> PathMATEPrafile Constraint
< EAnnotation umlz.isTemplate

" Comment ink

: 4y Constraint Link.
Class Diagram No name

|-,/ Class Diagram System Domain Dia
Additional Resources

= Properties “_[Z Problems | @ Action Languagﬂ = = O[5 bocumentation 52

E3 < <system>> <Model> SystemVodel

|

Model Name: SystemModel _I
Profiles
Stereotypes

/ Stereotype Attribtes

Graphics
Advanced

Outline View Properties View Documentation Viev\_lﬂ|

I~ ) Use HTML Editor A Edic

Comments | resources |

. 5]

|0

PROCEDURE: Use the Properties view to rename the System Model
1. If the QuickStart System Model.umldi file is not open, open it.

2. In the Outline View, select the Model QuickStart System
Model - the Model now appears in the Properties view:

1 Properties [3_\ Problems | 4@ Action Language ~ =0

B <<system>> <Model> QuickStart System Model

Model Name: | HuickStart System Model |
Profiles -
Visibilty: [ public 9|
Stereotypes ol
Stereotype Attributes
Advanced
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3. Using the Name field rename Quick Start SystemModel to
SimpleOven.

4. Hit Control-S to save your model changes.

5. Click the "X" in the Editor Pane tab to close the QuickStart
System Model.umldi file.

_g—
urs CQuickSkart System Mu:u:lel.u@ldi &3 ; ’
IQuickskart Models/ Quickakart Sy del, umnldi
[y Select package Simplewven )

r-q
R Margquee

NOTE - Generally the .umldi (UML Diagram Interchange) file is the only
modeling file we'll need to edit. Topcased has an important limitation in that
only a single .umldi file can be open at one time if it references a common
resource. We're closing QuickStart System Model.umldi so we can create
(and open) a new umldi file for the MicrowaveCooking domain model.

Task 2: Add the Modeled Domain MicrowaveCooking

PROCEDURE: Use the PathMATE Domain Template Generator to
Add the MicrowaveCooking Domain

1. In the Topcased Navigator view, select the Models folder in the
QuickStart project.

2. Select File > New - Other in the top menu bar. In the New
File Dialog Wizards field type Domain:

~ioix

Select a wizard

—

Wyizards;

IDDmaln =

= [ﬁb PathMATE for Topcased
= ¥10main Templake Generator

(7) = Back I Mext = I Einish Cancel

3. Under PathMATE for Topcased select Domain Template
Generator and click Next. The New PathMATE Domain dialog
opens:

10
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~1o| x|
Multi-page Editor File

This wizard creates a new file with *,.uml extension that can
be operned by a mulki-page editar,

Conkainet; | JouickstarkModels Browse, ., |

Eile name: | MicrowaveCooking) uml

(7 = Back Mext = | Finish I Cancel |

4. Ensure the Container field shows /QuickStart/Models, and in the
File name field enter MicrowaveCooking.uml|. Click Finish.

The new domain model appears in the Project Explorer.

5. In the Outline View select the domain MicrowaveCooking, and
in the Documentation View enter Highly simplified sample
domain to control the operation of a microwave oven.

5% Outline o L | i | %l = T O|[Eerre Eiro | @ati| = O Q Documentation &3 El console
=
Comments | Resources
<-<domain:>...aveCooking Highly simplified sample demain to control the operation of a microwave oven
Model Mame:

=-E2 <Model> MicrowaveCooking Profiles
<4 EAnnotation uml2.isTemplate Visibilit
. . Stereotypes
< EAnnotation http:/fwww. topcased. orgfdocumentation ;
imm} < <domain>> <Package> MicowaveCooking Stereotype Attributes
S, <Profile Application = PathMATEProfile Advanced
'= Additional Resources

[ ) Use HTML Editor
<>

6. Click outside the document view. Note, in eclipse changes in a
view aren't registered until it is no longer focused on.

7. Hit Control-S to save your model changes.
Expand <Package> MicrowaveCooking in the Outline View to see:

e A Domain Types package for user defined types within the
domain.

e A Domain class diagram. The class diagram is open in your edit
pane. See Create a Class Diagram for more information about the
domain class diagram.

e A Domain Support class that contains the domain initialization()
operation.

e A Domain Interface class for domain services. The class is a
published interface.

11
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PROCEDURE: Add a Domain Service to the MicrowaveCooking
Domain

1. In the Outline View select the Domain MicrowaveCooking and
expand it if necessary.

2. In the Outline View select the Interface Domain Interface and in
the Propertive View use the Name field to rename it MC
services. NOTE - this will be helpful when building Scenario
Models in later steps.

3. Right-click on MC services and select Create child > Owned
Operation > Operation.

4. Select the newly created Operation, and in the Properties View
name it ReportDoorStatus.

5. In the Documentation View enter Used by an external source
(the door contact switch) to indicate whenever the door opens
or closes.

In the Properties View Parameters Tab click Add.

Go to the Details of the Parameter section, and in the Name
field enter is_open.

8. At the right edge of the Type field select the type browser
button, and enter Boolean in the Search field:

£ Dbject selection 10Ol x|

Search ; | Boolean

|- Case sensitive

il = Primitive Tyvpe > Boolean
----- Y < <eDataTypes=> <Primitive Type > Boolean
----- L =<metaclassz> <Class> Literal Boolean

----- [F < «<eDataType == <Primitive Type = Boolean

o [F 2 <eDataTypes> <Primitive Type = Boolean Object

[:‘E] Ik I Cancel

9. Click OK.

10.In the Outline View, under the Operation ReportDoorStatus,
select the parameter is_open. In the Documentation View
enter TRUE indicates the door has opened, and FALSE indicates
it has closed.

11. Hit Control-S to save your model changes.

12
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PROCEDURE: Specify ReportDoorStatus Interface Operation Action
Language

To complete the ReportDoorStatus service, the PathMATE Action

Language view is used to specify the platform-independent action
language for the service.

1. If you do not have an Action Language View window open
(typically grouped with the Properties View), at the Eclipse top-
level menu select Window > Show View - Other.

_1ol x|
I.ﬁ.cticun H

= IEr PathMATE
E Action Language

IUse F2 to display the description For a selected wiew.

K I Cancel

2. Select the Action Language view and click OK.

3. In the Outline View, select the Operation ReportDoorStatus.
Ensure the context specification indicates the Domain service
MicrowaveCooking:ReportDoorStatus is in focus:

-

= Properties | (2 i nouage &4
Domain service MicrowaveCooking: ReportDoor Skakus

—

4. Copy the following PAL statements into the Action Language
View:

Ref<Door> door = FIND CLASS Door;
IF (door != NULL)
{

. IF (is_open)

p)

X

{
GENERATE Door:IsOpen() TO (door);
}
ELSE
{
GENERATE Door:IsClosed() TO (door);
}

13
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5. Hit Control-S to save your model changes.

6. Click the "X" in the Editor Pane tab to close the
MicrowaveCooking.umldi file.

14



PathMATE for Topcased 2.1 Quick Start Guide ﬁ Pathfinder

Solutions

Task 3: Create a Realized Domain

ExternalDeviceControl is a realized domain that specifies the model-
level interface for some hand-written code that interfaces with external
device hardware. This interface includes a published set of services
specified via an Interface Class, and a user-defined type
(enumeration) that supports it.

PROCEDURE: Use the PathMATE Domain Template Generator to
Add the ExternalDeviceControl Domain

1.

In the Topcased Navigator view, select the Models folder in the
QuickStart project.

Select File > New > Other in the top menu bar.

Under PathMATE for Topcased select Domain Template
Generator and click Next.

Ensure the Container field shows /QuickStart/Models, and in the
File name field enter ExternalDeviceControl.uml. Click Finish.

In the Outline View select the domain ExternalDeviceControl,
and in the Documentation View enter This domain provides a
control interface to external devices (like a light).

Click on the Stereotype Attributes tab.
Expand the Domain properties group.

Select the Analyzed property from the Domain group and
change its value from true to false:

g
| Properties

1 < <domain:>> <Package> ExternalDeviceControl

o N
Al PrDhIems} & Action Language] 5 ¥ =8

—+l

e
Model F'rupert}.-'. | Yalue
- [=I Darnain
Profiles Analyzed B ralse
Skerentypes Implementation Mame 1=
Stereotype Attributes Parse Actions ‘= true
) =
IR Spotlight Enabled = falze =
= | | LI_I

9. Hit Control-S to save your model changes.
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PROCEDURE: Add a UML Enumeration to ExternalDeviceControl's
Public Types

1.

6.

In the Outline View expand the Package ExternalDeviceControl,
right-click the Package Domain Types and select Create Child
- Owned Type -> Enumeration.

Expand the package Domain Types, select the newly created
Enumeration, and in the Properties View Model Tab name the
enumeration sys device_e.

In the Documentation View enter External device identifiers.

Right-click the new Enumeration and select Create Child >
Owned Literal > Enumeration Literal.

Expand the enumeration, select the newly created Literal and
using the Properties View name it SYS_DEVICE_LIGHT.

Hit Control-S to save your model changes.

PROCEDURE: Add a Domain Service to the ExternalDeviceControl

Domain
1.

N o u ok

10.

11.
12.

In the Outline View select the Interface Domain Interface and in
the Properties View use the Name field to rename it EDC
services. NOTE - this will be helpful when building Scenario
Models in later steps.

In the Outline View select the Interface EDC services, right-click
and select Create child > Owned Operation > Operation.

Select the newly created Operation, and in the Properties View
name it ActivateDevice.

In the Documentation View enter Activate the specified device.
In the Properties View Parameters Tab click Add.
In the Name field enter device_id.

At the right edge of the Type field select the type browser
button, and enter sys_device e in the Search field:

Click OK.

In the Outline View, under the Operation ActivateDevice, select
the parameter device _id. In the Documentation View enter
Specifies the id of the target device.

Repeat steps 1-8 to add another Domain Service
DeactivateDevice with a similar description and parameter.

Hit Control-S to save your model changes.

Click the "X" in the Editor Pane tab to close the
ExternalDeviceControl.umldi file.

Task 4: Complete the System Domain Chart
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In this task you will specify the Logical Architecture of the system in a
Domain Chart.

PROCEDURE: Use System Domain Chart to Specify the Domain
Hierarchy and their Dependencies

1. In the Topcased Navigator View double-click on the QuickStart
System Model.umldi file to open it.

2. In the Outline View expand the system.

The diagram open in the Editor Pane is the System Domain Chart
Diagram.

3. In the Outline View right click on Additional Resources, select
Load Resource and click the Browse Workspace button.

&= File Selection =10l ]
= TET CuickStark =l
Ellg Models

oot | ExternalDeviceContral.uml

[

(7) oK I Cancel |

4. Under QuickStart/Models select MicrowaveCooking.umldi and
click OK and OK.

5. Expand Additional Resources, MicrowaveCooking.umldi,
Diagrams, Model MicrowaveCooking, and drag the package
MicrowaveCooking onto the Domain Diagram, near the top.

6. On the Domain Diagram select MicrowaveCooking and drag the
Change Bounds box to resize the package symbol so only the
name portion shows.

<<[amain>>
v hicrowawveCooking =

I(frn:lm Min::rn:lwauec::lclkingjl

7. Right click on any diagram elements that do not belong and
select Delete from Diagram. Press yes to the following prompt.

8. Repeat steps 3-7 to load ExternalDeviceControl.umldi from the
QuickStart/Models folder and add its domain Package Symbol
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to the Domain Diagram, below and to the right of
MicrowaveCooking.

9. Repeat steps 3-7 to load SoftwareMechanisms.umldi from the
QuickStart/PathMATE folder, and add its domain Package
Symbol to the Domain Diagram, below and to the left of

ExternalDeviceControl.
10.In the Edit Pane tool palette select the Dependency tool

< DEPENAENCY Click in the MicrowaveCooking Package, and
then in the ExternalDeviceControl Package.

11.Repeat step 9 to create a dependency between
MicrowaveCooking and SoftwareMechanismes.

12.Click on any white space in the Diagram to bring up the
diagram properties in the Properties View.

13. Set the Page Format, to HalfPageFormat.
Your Domain Diagram may look something like this:

package SimpleOwen )

MicrowaveCooking
(from MicrowaweCooking)

: ExternalDeviceControl
{fram ExternalDevice Cantral)

!
W
SoftwareMechanisms
(from)

14. Hit Control-S to save your model changes.

PROCEDURE: Specify System Package Imports

In addition to specifying the Domain hierarchy, the file structure of
the system also needs to be identified. Specifically all domain
model files used in the system need to be imported.

1. In the Outline View right click the Model SimpleOven and select
Create Child > Package Import > Package Import.

2. Select the newly created Package Import.
3. In the Properties View select the Advanced Tab.
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4. On the right edge of the Imported Package field click the
package selector button:

5= outline i k- | =] = | u
E@ <Q<5Ystem>> <Model> SimpleCven ] Properties . (01 Problems} & Action Language} 5 B Y .0
H

<<class, housekeeping > <Class = Syskem Support =
A
" =Dependency > Dependencyl . < Package Import:-

" <Dependency Dependency? | T | D J_
F0 <Package> System Types Stereotypes 5 L
<Package Impart = Stereotype Attributes < <domain=> <Package: MicrowaveCol @
<Profile Application = PathMATEPrafile Advanced Wisibility '= Public

< EAnnotation uml2.isTemplate
:"': Class Diagram System Domain Diagram

5. Choose the domain Package MicrowaveCooking.

6. Repeat steps 1-5 to add Package Imports for
ExternalDeviceControl and SoftwareMechanismes.

7. Hit Control-S to save your model changes.
PROCEDURE: Capture a System-Level Scenario Model

Although a typical system constructed with PathMATE will have many
System-Level Scenarios, we will capture a single scenario to expose
the core concepts.

1. In the Outline View right click the Model SimpleOven and select
Create child > Nested Package > Package. In the
Properties View Model tab, name the new package System-
Level Scenarios.

2. Right click on the package System-Level Scenarios and select
Add Diagram > Sequence Diagram.

3. In the Properties View select the new Collaboration and use the
Model Tab Name field to name it Open Door.

4. In the Properties View select the new Interaction and use the
Model Tab Name field to name it Open Door also.

5. In the Documentation View add:
PRECONDITION - The system is running, and the door is closed.
POSTCONDITION - The light has been turned on.

6. Select the new Sequence Diagram. In the Properties view on
the Advanced tab, use the Name field to nhame the diagram
Open Door.

In the Editor palette pick the Lifeline tool 7 feine |

Click in the upper left of the Editor Pane. Delete the default
name and hit Enter (this creates a new lifeline with no name.)

9. In the Properties View click the Object selector (...) to the
right of the Represents field. Type EDC services. The Interface
EDC services should be selected. Click OK.

10. Repeat steps 7-9 to create a lifeline for MC services just to the
right of the EDC services lifeline.
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At this point your sequence diagram may look something like this:

interaction Open Door )

: EDC services : MC services

| 1
| |
| |
| |

11.

12.
13.

14.

15.

16.

17

18.

In the Editor palette pick the Execution extent tool
[@» Execution

Click on the EDC services lifeline just below the title box.

In the Editor palette pick the Call asynchronous tool
@ Call (asynch.)

Click once in the Execution extent box on the EDC services
lifeline, and again directly across from this on the MC services
lifeline.

Select the new Message line on the diagram, and in the
Properties View on the Model tab, click the Object selector
(...) to the right of the Operation field.

Pick ReportDoorStatus and click OK.

.In the Properties View, in the Value column for the is_open

attribute, select true. Click OK.

Repeat steps 11-15 to place a call from MC services to the EDC
services ActivateDevice operation.

At this point your sequence diagram may look something like this:

interaction Open Deur)

EDC services ' MC services

I I
I;j FeportDoorStatusitru ElD

I:;]/ ActivateDevice() !1
=

19.
20.

Hit Control-S to save your model changes.

Click the "X" in the Editor Pane tab to close the QuickStart
System Model.umldi file.
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Task 5: Complete the Class Diagram for the
MicrowaveCooking Domain

The MicrowaveCooking Domain is the heart of the application. In this
task you will complete the MicrowaveCooking’s Domain Class Diagram
by adding Classes, Attributes, and Associations.

PROCEDURE: Create the Oven, Door and Light Classes in the
MicrowaveCooking Domain

Topcased supports the creation of model element both from the Editor
Pane and the Outline View. We will do both.

1.

10.

11.

12.

13.

In the Topcased Navigator View double-click on the
MicrowaveCooking.umldi file to open it. The Domain Class
Diagram opens in the Editor Pane.

In the Outline View expand the Package MicrowaveCooking.
Select the diagram Class Diagram Main.

In the Properties view on the Advanced tab, use the Name field
to name the diagram MicrowaveCooking.

In the Editor pane, right-click on Domain and select Delete from
Diagram.

Click on any white space in the Diagram to bring up the
diagram properties in the Properties View.

Set the Page Format, to HalfPageFormat.

In the Editor Pane palette, select the Class tool = ©*

Click on the left side of the diagram. At this point the newly
create class symbol appears, and the default name is selected.
Type Door and hit Enter.

In the Outline View select the new Door class. In the
documentation view enter the description Microwave oven door
to cooking area.

Repeat steps 5-7 to create class named Light to the right of
Door with the description Light to illuminate cooking area.

In the Outline View right-click on the Package
MicrowaveCooking and select Create child > Owned Type >
Class.

Select the newly created class. In the Properties View on the
Model tab use the Name field to name it Oven.

In the documentation view enter the description Microwave
oven - central controller.
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At this point your class diagram may look something like this:

package MicrowaveCooking }

<<interface>>
ML services

+RepontDoorStatus (is_open - Boolean)

Door nght

Note: If the Domain Interfaces do not appear in the diagram, they
can be dragged and dropped from the outline view unto the MC
services box to be added to diagram.

Your outline view may look like:

- E— ' +, ([ 5= |
quouthl'ﬂ - v ._vaz _.,—|\ | i:g

= 21 =Model= MicrowaveCooking
=3 <«domain>> <Package > MicrowaveCooking
- g <<class, domaininterface > > <Interface> MC services
[+ ; < «class, housekeeping=> <Class> Domain Support
«<<class> > «Class> Door
<<class> > <Class> Light

< <class>> <Class= Oven

injimine

G
-
B=
[+ 3 «<Packagez Domain Types
) < EAnnotation http:/ s topcased. org/document ation
.. Class Diagram MicrowaveCooking
= ?;:, <Profile Application = PathMATEProfile
. < EAnnotation umlz.isTemplate
#'= Additional Resources

21.Hit Control-S to save your model changes.

PROCEDURE: Add Attributes to the Oven and Light Classes

1. In the Outline View right-click the Oven class and select Create
child > Owned Attribute > Property.

2. Expand the Oven class, select the new attribute, and in the
Properties view use the Name field to name it serialNumber.

3. Select the Type browser and enter String.
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The Properties view for the attribute may look like:

5= outline ’Tz}‘bHE = 7 = E

EEI <Model= MicrowaveCooking

[=-E3 <<domainz> <Package> MicrowaveCooking

- @ <=class, domainInterface= > <Intetface > Domain Interface

- Q <=class, housekeeping> > <Class > Domain Support

Q <<class>> <Class> Door

Q <<class>> <Class> Light

=- Q <<class>> <Class>
o

H-E <Package> Dol

[ < EAnnotation http:/hawe kopcased. orgfdocumentation

1./ Class Diagram MicrowaveCooking

etialMumber | Skring

] Properties . [21 Pmblams} & Action Language]

= =<attribute: > <Property:

Model

Specification

Stereotypes

Stereotype Attributes

Advanced

Mame;
Type:

Wisibiliby:

|saria|Number

I <Primitive Type:> String

Ipuhl\c

Multiplicity

Lower Bound:

Upper Bound:

|1

In

(-3, <Prefile Application PathMATEProfil

4. In the Documentation View enter Serial number for the overall
oven unit.

5. Repeat steps 1-4 to add to the class Oven a new attribute
dateOfManufacture of type String with the description The date
the oven unit was assembled, and ready to package and ship.

6. Repeat steps 1-4 to add to the class Light a new attribute

wattage of type Integer with the description The wattage of the
bulb in the light fixture.

7. In the Outline View, right-click the attribute wattage and select
Create child > Default Value > Literal Integer.

8. In the Properties View Advanced Tab type 60 in the Value field.
Your Outline view for the Light class may look like:

ElIEI < <class=> <Class = Light
: Ellgl < < attribute > <Property = wattage : Integer
ESSTN | jteral Inkeger = 60

9. Drag the Class Oven from the Outline View onto the top center
of the Class Diagram.

10. Drag the Light attribute wattage from the Outline View into the
center compartment of the Light class symbol on the Class
Diagram.

11.Right-click the Light class symbol on the Class Diagram and
select Graphical Properties > Auto Resize.
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At this point your class diagram may look like:

package MicrowaveCooking )

= <interface=>
ML services

+ ReportDoorStatus (is_open - Boolean) Oven
+senalNumber : String
+ dateOftdanufacture : String

Light
+wattage : Integer = 60

Door

22.Hit Control-S to save your model changes.

PROCEDURE: Associate the Classes

First we will adjust the display preferences for associations, then
we will create two associations in the MicrowaveCooking domain.

1. At the Eclipse top-level menu select Window -> Preferences
and navigate to Topcased > Editors > UML - Class
Diagram > Association.

2. Select middleNameEdgeObject in the Hidden Elements box:

& Preferences ol x|
Itype Filker bext Association P T
=- T:apcased ;I ~Edae
[=I- Editars

i Pange Formak Router : IOinque 'I
- Page Margi
--5:?: ardns Font:  Sans-regular-10 change. .. |

" SysML ForegroundColor: [ |
El- U!‘\"IL
[ Activity Diagram ~Edge Objects

-- All Diagram

(=} Class Diagram Yisible Elements

Association srchameEdgeObject

. AssociationClas sreCountEdgeCbject

targetMameEdgeTbject

- Class "
DiataT targetCountEdgedbject

o hatalype stePropertiesEdgeCbiect

-~ Enumer ation targetPropertiesEdgeobject

- Enumer ationLite

- izeneralization

- Instancespecifi

4| | g _’II;I Restore Defaults | Apply |

(7) ok I Cancel |

3. Click Show and OK.
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4. In the Editor Pane palette select the Association tool
7 Bssociakion

5. Click once in the Oven class symbol, and then again in the Door
class symbol.

6. In the Outline View select the new association. In the
Properties View on the Model tab, use the Name field to name it
Al.

7. In the Documentation View enter The oven has a door to seal
the cooking area during microwave emission.

On the First End tab, delete the text in the Role field.
9. On the Second End tab, enter is_part_of in the Role field.

10.In the Editor Pane right-click the association and select
Graphical Properties > Change Router:

£ Router selec x|

Please choose the tvpe of router ko use,

Cancel

11.Select Rectilinear and click OK.

12.Drag the line and label elements of the association to arrange
them in a clear manner.

13.Repeat steps 4-12 to create association A2 between Oven and
Light with a role phrase illuminates_interior on the Light end,
and a description The light illuminated the oven cooking area.

At this point your class diagram may look like:

package MinDW&VECDDking)

< <inkerface ==
MC services

+FReportDoorStatus (is_open : Boolean) i Oven 1
+sernalNumber : String
+dateOftdanufacture : String

Al Al

+

1 [ +illurninates_interiar

1 +i5_part_of

Light
+wattage : Integer = 60

Door

23. Hit Control-S to save your model changes.
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Task 6: Complete the MicrowaveCooking Domain
Initialization Action

PROCEDURE: Add MicrowaveCooking Initialization Action

The domain initialization action creates startup-time class instances in
the MicrowaveCooking domain.

1. In the Outline View select the housekeeping class Domain
Support.

2. Ensure the context is shown as MicrowaveCooking domain
initialization and click the Action Language View tab.

3. Copy the following PAL statements into the Action Language
View:

// Set up instances for MicrowaveCooking

f;wﬁ_. Ref<Oven> mw oven = CREATE Oven (
serialNumber = "G023-47z-8811",
dateOfManufacture = "2004/02/22; 10:41");

Ref<Light> interior light = CREATE Light (wattage = 25);
Ref<Door> door = CREATE Door();

LINK mw oven Al door;

LINK mw oven A2 interior light;

// Now just to start things off, open the door

GENERATE Door:IsOpen() TO (door):;

4. Hit Control-S to save your model changes.

Task 7: Create the Door State Machine

The door State Machine shows transitions between closed and open
states.

PROCEDURE: Create and Name the Door State Machine Diagram

1. In the Outline View right-click the Door class and select Create
child > Owned Behavior > State Machine.

2. Expand the Door class and right-click the newly created State
Machine and select Add Diagram - State Machine Diagram.
A new state machine diagram opens in the Editor Pane.

3. In the Outline View select the new State Machine. In the
Properties View Model tab enter in the Name field Door State
Machine.

PROCEDURE: Lay out Door States

In the Editor Pane palette, select the Region tool () Region

2. Click on the Editor Pane to place a region. (It is a box that
lines up with the original state machine diagram borders so you
really don’t see anything new.)

3. In the Editor Pane palette, select the Initial pseudostate tool
@ Initial
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4. Click in the top area of the diagram to place the Initial
pseudostate. Type initial to name it.

In the Editor Pane palette, select the State tool “~=%

Click just below the Initial pseudostate to place the State. Type
Closed to name it.

7. Repeat steps 5-6 to create a state Open just below the Closed
state.

PROCEDURE: Change State Machine Diagram Transition
Preferences

1. At the Eclipse top-level menu select Window - Preferences
and navigate to Topcased -> Editors > UML > STM Diagram
- Transition.
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2. Select the Router choice Rectilinear:

& Preferences =10l =
|tv|:|e Filker text Transition - ¥
B- Tu::upcas_ed ﬂ ClEse
[=]- Editars
Page Format Router @ | EiEedllgl==Ty
- Page Margi |
.. 52.3'18 e Font: Sans-regular-10 Change. ..
" SysML ForegroundColor: N |
=Ll
- Activity Diagram —Edge Chijects
- &l Diagram - )
sz B Yisible Elements Hidden Elements
Companent Diagran nameEdgeCbject Hide = | TransitionStereatypeEdgeChject

Cormposike Diagram
Dieplayrient Ciagrar = Show |
Profile Diagram
Sequence Diagram
STM Diagram

- CompositeState

- izonneckionPain

- Final3take

- PeeudostateCh

- PseudaostateDen

- PeeudostateEnt

- PeeudostateExi

- PeeudostateFor

- Peeudostakelnit

- Pseudaostake Joi

- Peeudostate Jur

- Peeudostatesh:

- PseudostateTer
- Region

- State

- Submachinestal

&8 Transition p
4| » Restore Defaulks | apply |

3. Click OK.
PROCEDURE: Draw an Untriggered Transition

1. In the Editor Pane palette, select the Transition tool
—= Transition ]

2. Click once in the initial pseudostate, and again in the Closed
state.

3. In the Outline View select the new transition. In the Properties
View on the Model tab, delete the name (typically Transition1)
from the Name field.
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PROCEDURE: Create Signals, Triggers and Draw a Triggered
Transition

Transitions can be triggered by Signals which can be defined with a

State Machine. However in Topcased a Signal must be tied to a
Trigger with a Signal Event, which can only be defined under a

package. So we will use a separate package Signal Events for these

event elements.

1.

In the Outline View right-click on Package MicrowaveCooking

and select Create child > Nested Package > Package.

Name the new Package Signal Events.

In the Outline View right-click on the State Machine Door State

Machine and select Create child > Nested Classifier >

Signal.

Select the new Signal and name it IsOpen. In the
Documentation View enter Indicates the Door has opened.

Your Outline View may look like:

Elg < =rlassxx <Class > Door

EII:' < <class == <5kate Machine> Door State Machine
=1 <Region= Region1

'1—2' <<stake == <State > Closed

t_J < <state s> <States Open

@ < =kransition = <Transition:>

o @ <Pssudostate s initial

<5ignal = [sCpen

------ & state Machine Diagram unnamed

[+~ < E&nnatation btkp: ) v, bopeased., orgfdocurent ation

[+ <+ EAnnotation hekp: s, bopcased, orgfdocument ation

In the Outline View right-click on Package Signal Events and

select Create child > Packaged Element > Signal Event

(you may need to scroll down the list to find it.). Name it

Door:IsOpen.

In the Advanced Tab Signal field select the IsOpen signal.

Your Outline View may look like:

F- " zhssociation= A2

. B3 <Package> Signal Events
S A <Signal Event> Door:IsOpen

<Package> Domain Types

< EAnnatation htkp:f e topeased, orgfdocumentation
", Class Diagram MicrowaveCooking

S <Profile Application PathMATEPrafile

"4 EAnnotation umlz.isTemplate

] Properties |21 Problems | @ Action Language}

< Signal Event> Door:IsOpen

Maodel

Propetk:
= UML

Skereotypes

Client Dependency

Stereotype Attributes

Marne

[#-1= additionsl Resources -
=1 i S

Advanced

In the Editor Pane palette, select the Transition tool

—= Transikion

Click once in the Closed state, and again in the Open state.

In the Outline View select the new Transition.
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9. In the Properties View Model tab, delete the name from the
Name field.

10.0n the Triggers tab, click Add. Select the new Trigger in the
Triggers list.

11.Click the Event selector, and select the Signal Event
Door:IsOpen:

] Properties [3_ Prnblems} & Action Language} = =08

@ < < transition= > < Transition>

Model Triggers
F{% Triggers ?%?ET“QEIED I
Guard
Effect

Stereotypes Trigger Details
Stereatype Attributes i § l |

Advanced

201l = Signial Event > Door:IsOpen EI

Your State Machine diagram may look something like:

state machine Doaor State kMachine )

<{State»>
Cloged

DoorlsOpen

<<Stater»
Open

12. Hit Control-S to save your model changes.

13.Repeat steps 2-11 to add a new Signal IsClosed with the
description Indicates the Door has closed, a corresponding
Signal Event. Have it trigger a transition from the state Open
to the state Closed.
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Now your State Machine diagram may look something like:

state machine Doar State kachine )

<<Statex»
Closed
<<Stater>
— Cpen

14. Hit Control-S to save your model changes.
PROCEDURE: Capture Door State Entry Actions

1. In the Outline View right-click on the Door State Machine
Closed state and select Create child > Entry > Activity.

2. Select the new Activity and in the Properties View on the Model
tab in the Name field enter the Action Summary Generate
TurnOff to the light.

3. In the Action Language View copy the following PAL
statements:

DoaorlsClosed DoorlsOpen

Ref<Light> interior light = FIND this->Al->A2;
GENERATE Light:TurnOff() TO (interior light);

¢

4. Right-click the Closed state symbol on the State Machine
Diagram and select Graphical Properties > Auto Resize.

5. Repeat steps 1-4 for the Open state entry action, using the
following PAL statements:

Ref<Light> interior light = FIND this->Al->A2;
GENERATE Light:TurnOn() TO (interior light);

¢
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Now your State Machine diagram may look something like:

state machine Doar State kachine )

inifial

4 <<State>> o

Closed

entry | Generate TurnOff ko light
_ . A
DoorlsClosed DoorlsOpen

" <¢Stater> ™

Cpen

entry | Generake TurnOn to light
" ~

6. Hit Control-S to save your model changes.

Task 8: Create the Light State Machine

This section will briefly recap the steps needed to capture a state
machine as you build the Light. If you are unsure exactly how to
proceed, please review the detailed Procedures in Task 7 above.

PROCEDURE: Create the State Machine Diagram and States

1. In the Outline View right-click the Light class and select Create
child > Owned Behavior > State Machine.

2. Right-click the State Machine and select Add Diagram >
State Machine Diagram. Name it Light state machine.

3. Place a region with (0 Region

4. Place an Initial pseudostate ® Intidl and name it initial.

5. Place states Off and On with “=*&€
PROCEDURE: Draw Transitions

1. Create a transition from initial to Off with == Transition  pajate

its name.

2. Create additional transitions from Off to On, and from On to
Off.

3. Click once in the initial pseudostate, and again in the Closed
state.
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4.

Hit Control-S to save your model changes.

PROCEDURE: Create Signals, Triggers, and apply them

1.

7.

In the Outline View right-click on the State Machine Light State
Machine and select Create child > Nested Classifier >
Signal. Name it TurnOff, and give it the description Indicates
the light is to be deactivated.

Repeat step 1 for the Signal TurnOn with the description
Indicates the light is to be activated.

Right-click on Package Signal Events and select Create child >
Packaged Element > Signal Event twice. Name them
Light:TurnOn and Light: TurnOff.

In the Advanced Tab Signal field select the TurnOff and TurnOn
Signals appropriately.

On the Editor Pane select the Transition from Off to On. In the
Properties View Model tab, delete the name from the Name
field. On the Triggers tab, click Add and select Light:TurnOn in
the Event selector.

Repeat step 5 for the Transition from On to Off, selecting the
Event Light: TurnOff.

Hit Control-S to save your model changes.

PROCEDURE: Create State Entry Actions

¢

¢

1.

In the Outline View use Create child > Entry > Activity to
add an Entry Action Activity to the Off state. Name it
Deactivate device with ExternalDeviceControl. In the Action
Language View copy the following PAL statement:

ExternalDeviceControl:DeactivateDevice (SYS DEVICE LIGHT);

2.

Add an Entry Action Activity to the On state and name it
Activate device with ExternalDeviceControl. Copy the following
PAL statement:

ExternalDeviceControl:ActivateDevice (SYS DEVICE LIGHT);

3.

On the State Machine Diagram do Graphical Properties >
Auto Resize on both states.
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Your Light State Machine diagram may look something like:

>

state machine Light state machine )

<<Stater> ™
Diff

L entry | Deactivate device with ExternalDeviceControl

-~

Light: TurnOff LightTurnOn

. <<Stater> ™
Cin

entry | Activate device with ExternalDeviceControl
" ~

4. Hit Control-S to save your model changes.
5. Close MicrowaveCooking.umldi.

Congratulations! Your QuickStart project
has a Real Model.
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Prepare for Transformation

You now have a complete, executable platform independent model and
your project is just a few steps from being ready for transform into an
executable system. You'll reuse some items from the SimpleOven
Example project which comes with PathMATE. This section takes you

through the following steps:
e Navigate to the complete sample SimpleOven project and use it as
a reference, copy C++ and Java transformation properties and
realized code from it.
e Add a PathMATE Project to the QuickStart project which will
control transformation and deployment.

e “Smoke Test” your model by generating documentation from it.

Task 1: Reuse elements from Example Project

SimpleOven exists as a sample model in the PathMATE profile. We will
use the existing SimpleOven project as a reference project to copy the
realized ExternalDeviceControl implementation code and
transformation markings/properties that guide the automatic
generation of a C++ and Java implementation for this system.

PROCEDURE: Instantiate a Reference Project for SimpleOven
1. From the Eclipse base menu select File > New >

Example.
2. In the Wizards field start to type SimpleOven.
& Mew Example ~1of x|
Select a wizard —
Wizards:
ISimpIe W

[& Operational QYT Transformation
[,:“b PathMATE for Rhapsody:
ElEr PathMATE for Topcased

...... l@h

SimpleCven

(7) = Back I Mexk = I Einiish Cancel

3. Select Next.
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4. Name the project ReferenceSimpleOven and click
Finish.
5. Press Finish.

PROCEDURE: Use Eclipse Resource Perspective to Copy Files
Needed for C++ and Java Systems

1. Ensure you are in the Eclipse Resource perspective.
Typically this is done from the upper right of your
Eclipse desktop, but on your first time in you may
need to use the Eclipse menu Window -> Open
Perspective > Other and select Resource.

2. In the ReferenceSimpleOven project Models folder,
select the cpp folder, right click and select Copy.

3. Select the QuickStart project Models folder, right
click and select Paste.

4. Repeat steps 2-3 for the java folder.

Task 2: Connect PathMATE Project to your new PIM
PROCEDURE: Create a New PathMATE Project

1. In the QuickStart project Models folder select the
QuickStart System Model.umldi file.

2. From the Eclipse base menu select File > New >

Other.
3. In the Wizards field start to type PathMATE Project:
ol x|
Select a wizard
Create a PathMATE project.
Wyizards:
fPath -

== PathMATE

------ +¢| PathMATE PlatForm Model

(7) = Back I Mext = I Finish Cancel

4. Select PathMATE Project and click Next.
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5. Under the QuickStart project Models folder select
the QuickStart System Model.umldi file and click
Finish.

6. The PathMATE project file opens in the Editor Pane.

Task 3: Check Your Model

Before going on, this is a good point to check for any errors that may
have occurred in entering your model.

We will use the PathMATE documentation Transformation Map A/l
Reports and have the PathMATE Transformation Engine automatically
validate our model. The transformation maps applied in this procedure
can optionally be controlled by markings specified in a properties.txt
file, but we will not use one in this case.

PROCEDURE: Use the PathMATE Project Editor to test Your Project

1. In the Editor Pane select the deployment, All
Reports from the Deployment pick list.

2. Click Transform. A progress dialog will appear.
When it finishes, your Console window will show
your results.
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3. Verify no model extraction errors, or other errors
are listed.

&) *Quickstart SYSTEM MODEL . pathmate 52

PathMATE

PIM: |platform:Il'resource,l'QuickStartIl'QuickStart°f02DSVSTEM°a’o2IJMODI |

Deployment: IF\” Repaorts |z|| |TransForm |
=1l Path MATE Project

E|D Deployments

[ Transformations
“[21 Marking Sets
[#-52 Platfarm Models

~ ZE Single Process C++
<3 Single Process

-3 Single Process Java
B+ Al Reports
& export actions

1

m

PathMATE Comsole

ParnMATE

Project

Froducin
Cutput D

Template

PathMATE

Transforming Deployrent 'Ll]l Reports'
Socope System

Tue MNowv 13 12:40:47 GMNT-05:00 2007

Transformation Map 'PathMATE Reports'
Verifyving templates...Done

E}m-ﬂel
e sdomain MicrowaveCooking. ..
.« domain 3oftwareMechanisms. ..
.. .domain ExternalleviceContraol...

Extraction succeeded.

lng actions...done

Properties file properties.txt not found.

'platform: /resource/ Quick3tart/QuickStart ITITEM M

irectory 'C:/rsm 7 work/QuickStart/reports'
Cutput:
Transformation Engine - Tue Now 13 12:40:47 GHMT-0O

4. Check in the Project Explorer that you have the
generated documentation files. If not, you may
have a problem with your model.
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5.

=

Ell:5 uickSkart
B c
[ cpp

l:? al_xref

(= ascil_dump

(= ExtractedDiagrams
(= PAL_for_debug

=] .project
%2d ExternalDeviceContral, ermx

G8a QuickStark S¥STEM MODEL . e
o] GQuickStark S¥STEM MODEL. pathmate

----- |=| completeness, kxt
----- |=| consistency, bxk
----- [=| SimpleCven_Externalleviceontral_trimming_
iﬂ_ﬂ SimpleCyven_MicrowaveCooking_summary rkF
iﬂ__l)l SimpleCyven_MicrowaveCooking, rtf

E"_ﬂ SimpleCrwven_skatistics, csy

lﬂ-ﬂ SimpleCrwen_summary. rkfF

A Simplecven, it

24 MicrowaveCooking. emx

Some problems that might turn up are:

« Extraneous elements that were created in the

process of experimentation are not fully
specified.

« Spaces in Names; e.g. “External Device
Control” should be “ExternalDeviceControl”.

« Type not specified for a parameter.

o Issues with directory structure.

Correct

then return to QuickStart System Model.pathmate

any problems identified in the messages,

in the editor pane and click Transform again.

Congratulations! You are Ready to
Generate Real Code, Real Fast.
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Generate C++ Code and Visual Studio
Project Files

You are now ready to generate C++ implementation code and Visual
Studio project files.

e Configure Development Environment Options

e Transform Your Model to Code and Project Files

NOTE - if you prefer to generate Java implementation code, please
skip ahead to the Generate Java Code section.

Task 1: Configure Development Environment Options

The markings file properties.txt controls many aspects of
transformation, inclusion of “"Execution Instrumentation” in runtime
code to support the Spotlight debugger and IDE environment when
generating IDE project files. The markings file is located in the project
folder for the implementation language you are generating. So for
C++ generation, it is in the QuickStart/cpp folder.

PROCEDURE: Use Eclipse Text Editor to Enable Spotlight
Instrumentation by Changing “"Markings” in properties.txt

1. Double click properties.txt to open it.

[ *Project Explarer 2 = O i) quickstart System Modsl, pathmate m =8
2% v # The following markings are used to set up the Visual Studio project files
5 QuickStart Systewm, Simpledven, Inplementationlanguadgs , cpp
(22 Dragrans Domain, SimpleOven.ExternalDeviceControl, RealizedPath, . .\realized cpp
= % Modsls System, Siwplecven, Defines, PATH_USE_REALIZED _TYPES:PATH NO_INPUT_DRIVER
== opp : : : X X
M= g # Default is M3 Visual Studio version 7 (.NET) - uncomment these lines for M3 Visual Studio wersion 6

(= realized_cpp #3ystem, SimpleCven, Target IDE, VS6
B pmpert\;s bt #Domain, Simpledven. Softwarelechanisms, RealizedPath, o pathwatet designl cppiwechanisms

M) Guickstart System Model. pathmate
#-1=F ReferenceSimpleOven

2. Add the following as the top line:

‘ Domain, SimpleOven. *, SpotlightEnabled, T
3. Add the following as the bottom line:

‘ System, SimpleOven, Defines, CRT SECURE NO DEPRECATE; AFX NOFORCE LIBS

4. If you are building on Linux also add the following
as the bottom line.

‘ System, SimpleOven, TargetOS, Linux
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5. Select File > Save to save the changes.

PROCEDURE: Change Markings to select versions of Visual Studio

The default target when generating IDE project files is to support
Visual Studio version 7 (SimpleOven.vcproj). To generate Visual
Studio version 6, 8 or 9 project files, change properties.txt to specify
Visual Studio 6 is the Target IDE.

If you are using Visual Studio version 7, skip this procedure.

1. Uncomment the second-to last line in the file.

2. Leave the value VS6, or change it to VS8 or VS9 as
appropriate.

3. If you set TargetIDE to VS6, also uncomment the
last line in the file:

[ *Project Explarer 2 = B || & quidkstart System Model.pathmate m =0
B& < Dowain, SimpleOven. *, SpotlightEnabled, T
= 15 Quidstart # The folloving markings are used to set up the Visual Studio project f£iles
g Diagrams aysten, Sinpledven, Inp lenentat ionLanguage , cpp
- oddls Domain, SimpleOven.ExternalDeviceControl, RealizedPath, . .Yrealized cpp
26 epp System, Simpledven, Defines, PATH_USE_REALIZED _TYPES:PATH MO INPUT_DRIVER
Eoc ; ; ; ;
(= reslized_cpp # Default is M3 Visual Studio version 7 (.NET) - uncomment these lines for M3 Visual Studio version 6
B Dmpgm‘ai o System, SimpleOven, TargetIDE, V6
@ Cuickstart Sy;tem Madel. pathmate Domain, $impledven. SoftwareMechanisms, RealizedPath, o'\ pathmate’ designh cppimechanisms

= ReferencesimpleCven

4, Select File > Save to save the changes.

Task 2: Transform Your Model to C++ Code and Visual
Studio Project Files/Makefiles

PROCEDURE: Generate C++ Implementation Code and a Visual
Studio Project File/Makefiles

1. Open QuickStart.pathmate in the editor pane.

41




Solutions

PathMATE for Topcased 2.1 Quick Start Guide ﬂ Pathfinder

2. Verify that the deployment Single Process C++ is
selected in the Deployment pick list.
.pathmate X =00
PathMATE Deployment
PIM: | platform: fresource/QuickStart/QuickStart System Model.emx | [Change... ] ame: ‘ Single Process C++ |
Deployment: ‘L| [Transform] Working Dir: | PROJECT_DIRfcpp | [Erowsa... ]
=] @ Path MATE Project Resolved location: C:jDocuments and Settingsftomh/IBM|rstionalsdp7. 0fwarkspace/QuickStart fepp
=3 Deployments Transformation: |DEFBLI|t CH+ :|
&E Single Process C++
&E Single Process C
&E Single Process Java
&E Al Reports
JE export actions
(23 Transformations
23 Marking Sets
53 Platform Models
3. Click the Edit... button to the right of the
Transformation drop down. In the Transformation
Maps window ensure the PathMATE C++ and Build
file generation Maps appear in order. If not, use
the Add and/or Up/Down buttons to get both maps
to appear in the proper order.

o | R‘ [El *properties txt =
PathMATE Transformation ks
PIM: |p\atfnrm:)’resource,iQu\ckStartJ‘QuickStart System Model e | [Change...] Mame | Default C++ |
Deployment: |SingleProcess C++ ‘_'| [T’ansfnrm] Transformation Maps

=+l path MATE Project
=3 Deplayments
&F Single Process C++

&E Single Process Java

3& All Reports

§E export actions
=3 Transformations

= Default C++

= Default ©

Euild File generation - makefiles and project fi
PathMATE C
PathMATE Java
makefile for Java
PathMATE Reparts

Select the transformation maps used by this transformation.

PathMATE C++

Add,..

&E Single Process C # Add Transformation Map _ te

Down

Edit...

Remove

= Default Java
= Default Reparts
= expart actions

(3 Marking Sets
5% Platform Models

Marking Set: < Mo Markings = v

PAL Symbols

Define PAL Symbals,

1<
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Bl *properties.txt =
PathMATE Transformation s
PIM: | platForm: fresource/QuickStart/ QuickStart System Madel, emx | [Change‘.. ] Mame | Default C++ |
Deployment: | Single Process C++ v | [Transfgrm ] Transformation Maps

Select the transformation maps used by this transfarmation,

=y Path MATE Project

=3 Deployments PathMATE C++ Add. ..
&F Single Process C++ : £
&F Single Process C
& Single Process Java
3E All Reparts
&F export actions

= £3 Transformations
= Defaul: C++
= Defaul €
= Defaul: Java
= Default Reports
= export actions

(23 Marking Sets Marking Set: < No Markings = v

2 Platform Models

Markings
Select the set of markings to use.

PAL Symbols
Define PAL Symbals,

10 1

4. Click Transform. A progress bar appears.

5. Verify in the Console tab that both transformations
were successful. (If any problems arise at this
point they are like due to properties.txt typos.)

Mmookmarls Action Language | Search 5™ ;ﬂ ) f{j >~ =0
PathMATE Console

PathMATE )
Transforming Deploymwent 'Single Process C++'

Scope System

Project 'platform:/resource/QuickStart/QuickStart System Model.pathmate'

Tue Lpr 03 10:26:56 GMT-05:00 2007

Transformation Map 'PathMATE C++!
Using cached tewplates.

Transformation Map 'Build file generation - makefiles and project files'
Using cached tewmplates.

Transformation Map 'PathMATE C++!
Extracting model
. ..domain SoftwareMechanisms. ..
...domain ExternalDeviceContraol...
«e.domain MicrowsveClooking. ..
Extraction succeeded.
Parsing actions...done
Producing Target Documents
Cutput Directory 'C:/Documents and Settings/towh/ IEM/rationalsdp7.0/workspace/QuickScart/cpp’

Template COutput:

PathMATE Transformation Engine - Tue Apr 03 10:Z6:56 GMT-05:00 zZO07

=]

Task 3: Build an Executable System

In the resource perspective, browse to QuickStart\cpp\MAIN. To
launch the Visual C++ environment and build SimpleOven.exe:
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PROCEDURE: Build SimpleOven.exe - Visual Studio Version 7+

1. Right-click SimpleOven.vcproj under QuickStart,
cpp, MAIN in the Project Explorer and select Open
With > System Editor.

2. Build the SimpleOven system in Visual Studio 7.

PROCEDURE: Build SimpleOven.exe - Visual Studio Version 6

1. Right-click SimpleOven.dsw under QuickStart,
cpp, MAIN in the Project Explorer and select Open
With > System Editor.

2. Build the SimpleOven system in Visual Studio 6.

PROCEDURE: Build SimpleOven.exe - GCC

1. In a terminal window navigate to the cpp/MAIN
folder.

2. Run the command make -f SimpleOven.mak

Congratulations! You now have a complete C++
implementation and project file for your system!

Please skip the Generate Java and Build with Eclipse IJDT section and move
ahead to the Run SimpleOven with Spotlight section.
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Generate Java and Build with Eclipse IJDT

The Eclipse Java Development Toolkit (JDT) is included with the Eclipse
installation that comes with PathMATE. This section takes you through
the following steps:

e Instantiate a Reference Project

e Create a JDT Project to build the generated code
e Create a PathMATE Project

e Transform Your Model

e Build an Executable System

NOTE - you should skip this section if you just completed the
Generate C++ Code and Visual Studio Project Files section and
do not want to build the Java implementation of your system.

Task 1: Set Up Java and Generate Java Code

Depending on the state of your Eclipse workbench, you may need to
activate the JDT capability.

PROCEDURE: Enable Java Development in you Eclipse Workbench

1. Enable the Java Development capability. Select Window >
Preferences... from the main menu bar. Select General/
Capabilities from the tree on the left side of the dialog. If you do
not see a Capabilities option, then skip this step. Click the
Advanced... button.
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2. Expand Development and ensure Java Development is checked.
& Advanced E Xl
Capabilities:
S W <cmert
= lava Development
‘O @ Plug-in Developrment
[ Modeling
- [ Team
Enable all | Disable All
Description:
Use the Eclipse 30K to develop applications, ;I
(7] 0K, I Cancel |

3. Click OK on both dialogs.

PROCEDURE: Generate Java Code

1. Open your PathMATE project file in your QuickStart project. Select

Single Process Java under the Deployments. Click Transform.
PathMATE

PIM:

| platform:,l'resource,l'QuickStart|

Deployment: ISiI'I';I|E Process Java |E|| ‘ Transform ‘

=l Path MATE Project

-3 Deployments

P &F Single Process C++
&F Single Process C
Single Process Java
gF &l Reports
&F export actions
Transformations
"2 Marking Sets
H-53 PlakForm Models

bea
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2. Verify no model extraction errors, or other errors are listed.

PathMATE

Transforming Deployiment 'Single Process Java'

Sope System

FProject 'platform:/resource/QuickStart/COuickStart SYSTEM MODEL.pathmate’
Tue MNov 13 12:585:15 GMT-05:00 2007

Transformation Map 'PathMATE Java'
Verifying templates...Done

Extracting model
.. .domain MicrowaveCooking. .
.. odomain Softwarelechanisms. .
.. edomain ExternalleviceCon

Extraction succeeded.

Taﬁug HoCIomn=. . . Ccone

Producing Target Documents

Qutput Directory 'C:/rswm 7 work/QuickStart/java/gc'

Template Output:
PathMATE Transformation Map for Java code tewmplates wersion 5.02.004
PathMATE Transformation Engine - Tue MNow 13 12:55:15 GMT-05:00 2007

Task 2: Create a Java Project Ready the System for Debug

PROCEDURE: Create a Java Project and Build
1. From the main Eclipse menu select File > New > Project.
2. The New Project Wizard Appears.
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3. Select Java / Java Project from Wizards.

i New Project |

Select a wizard

Create a Java project |

Wyizards:

| kype filker bexk

----- 3 Java Project from Existing Ant Buildfile ;I
----- 1_;[;2 Plug-in Project

----- =5 LML Project

[ General

RS i

[~ Eclipse Modeling Framewoark
-[== EMFT JET Transfarmations
== Java

Tg Java Proj
“ 4 Java Project from Existing Ant Buildfile
(= Madeling

[ Pluglets

~[— Examples -

- - - -

ek

[T sShow all Wizards,

(7) = Back I Mexk = I Finish Cancel

4. Click Next. The Create a Java Project page appears.
5. Enter the name SimpleOvenJava. Click Next.
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6.

i New Java Project i:: x|

Java Settings e
Define the Java build setkings.,

If there is no src folder under the top level folder, click Create
new source folder. Enter the Folder name src. Click Finish on
both dialogs.

L Source IE- P'ru:ujeu:tsl =i Libraries 4}4} Crder and Expork

G2 &2 | | e v in (& 5 @
SIES=d CuickStart Jawva

------ 2 (default package)

» Details
No Create new source Foldeps/use this if wou want to add a new source Folder ko wour =
S——
i) =

& Link additional source: use this if vou have a folder in the file svstem that should be—!

used as additional saurce Folder,

@ Configure inclusion and excusion filkers: specify patterns to the inclusion and ;I

™ allow output folders For source Folders

Defaulk output Folder:

| Quickstartlava Browse, ., |

_. ........ {Eal:k ......... MEX’: } | IWI Cance|

In the Package Explorer browser in your QuickStartjava project
select the src source folder, right click and select New >
Package.

Enter realized java for the package name, and click Finish.

In the Package Explorer browser, navigate in the QuickStart project
java/realized_java folder, select
ExternalDeviceControlRealized.java, and hit control-C to copy it.

10.Back in your QuickStartjava project select src/realized_java, and

hit control-V to paste in ExternalDeviceControlRealized.java.
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11.1In the Package Explorer browser, select your QuickStartjava
project, right click, and select Build Path <> Link Source...

12.Click Browse..., navigate to c:\pathmate\design and select the
java folder.

13.Click OK.
14. Enter pathmate_java_runtime in Folder name.

& Link Source

Source folder

To avoid overlapping, the existing project source Folder entry will be :E

replaced and the oukput Folder set to 'QuickstartJavalbin',

Linked Falder lacation:

|C:'|,pathmate'|,design'l,java Browse. .. | Eariables...l

Folder name:

| pathrnate_java_runtime
% Replace existing project source folder entry to salve nesting

" Update exclusion filters in other source folders ko solve nesting

(7) = Back Mext = | Finish I Cancel

3. Click Finish.

Select File > Switch Workspace > Other. Hit control-C to
copy the pathname of your current workspace from Workspace
field. Click Cancel.

5. Go back to your QuickStartiava project, right click, and select
Build Path > Link Source again.

6. Paste your workspace pathname into the Linked folder location
field, click Browse... and navigate to the generated code in your
QuickStart project: <your Eclipse
workspace>/QuickStart/Models/java/gc. Name this folder
generated _code.

Click Finish.

Verify that your QuickStartjava project has these contents:
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[=-% = QuickStartlava
E”E?sm
E|EEr realized_java
|J_| ExternalDeviceontrolRealized. java
=438 generated_code
Er'é PAL_For_debug
8 Simplecrven.ExternalDeviceControl
H Simplecrven. MicrowaveCooking
'—-B Simpledren. Sy
'—-B Simpleven. Sys
(= META-INF
build_SimpleCven,bat
‘oo || Simpledrven_ExternalDeviceontral_trimming_results, bxk
=438 pathmate_java_runkime
'—-B instrumentation
'—-B mechanisms
Er'é templates
Er'é templates_|ocal
build_templates.bat
@ PathMATEMapJavaReleaseMotes. doc
! ﬁ] PathMATEMaplavaReleaseMotes, pdf
[#-B5 JRE Syskem Library [jdk]

9. At this point your system should have automatically been built.
Verify your Problems window reports no Errors. (Some Warnings
are expected.)

PROCEDURE: Change Markings and Defines to Enable Spotlight
Instrumentation

1. Open QuickStart/java/properties.txt. The properties.txt file
appears in the Editor pane.

2. Add the following to the top of properties.txt :

}“k | Domain, SimpleOven.*, SpotlightEnabled, T

3. Select File > Save from the main menu to save the changes.

The markings file properties.txt controls many aspects of
transformation, including Spotlight debugger configuration.

1. In addition to generating instrumentation code (controlled by
the SpotlightEnabled marking) you will need to enable Spotlight
instrumentation in the runtime layer. In the Package Explorer
view, expand QuickStartJava > pathmate_java_runtime >
mechanisms.

Double click to open PfdDefine.java. The file opens in the
Editor pane. Set the NO_PATH_IE to false as shown below:

2
Q.
= public static final boolean NO PATH IE = false;

3. Select File > Save from the main menu to save this change.
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PROCEDURE: Create a Debug Configuration and Smoke Test it.

1. Go to Window/Open Perspective to switch to the Debug
perspective.

2. Select Debug.../Debug Configurations from the debug toolbar
menu

The Debug dialog appears.

Select Java Application from the Configurations tree.

Right click and select New.

Enter QuickStart in the Name field.

Select QuickStartjava for the Project if it is not selected already.

©® N U kAW

In the Main Class section, press the Search... button. The Select
Main Type dialog appears.

9. Select SimpleOvenApp from Matching Items and click OK.

10.Click Debug. This starts the system. In the Console window you
will see the program has started and is trying to connect to
Spotlight:

=
Problems | Javadoc Declaratiunm L]

Quickskark [1ava Applicakion] C:\Pragram Files\ IEMISDP 7O AR Bintjavaw, exe (Mow 13, 200
Tazk waiting for Spotlight conhection ok port 5150, ..

11.Press the Terminate button = . (We will connect to Spotlight in
the next section).

To debug this application at a later time, go to the Debug button and
select 1 QuickStart:

ﬁ"ﬁ'b‘lu'gi'

1 Quickstart

Cebug As »

ﬁ: Cebug. ..

Organize Favarites. ..

Congratulations! You now have a complete Java
executable for your system!
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Run SimpleOven with Spotlight

Task 1: Start the Simple Oven executable with Spotlight

Run the new program with the Spotlight to visualize SimpleOven
system execution at the model level.

A command window opens to say that the application is running and
waiting for a connection to Spotlight.

Please choose the appropriate Procedure below to start the
SimpleOven executable, depending on whether you built it in C++ or
Java.

PROCEDURE: Run C++ SimpleOven from Visual Studio
If you built Java, please skip this procedure.

1. Launch the application from within Visual Studio
(usually Debug »> Start Debugging, or the F5
key). A command window opens to say that the
application is running and waiting for a connection
to Spotlight.

Eile Edit %ew Project Buld Debug Tools Window Help

Debug - c AR E
n
Solution Exp’

S
E Solution SRR
+ sin

mpleOuen/SYS_TASK_ID_MAIN waiting for PathMATE Spotlight comnection on pofpy
=

%= Windows Security Alert

iy help protect your computer, Windows Firewall has blocked
some features of this program.

Do you want to keep blocking this program?

D Mame: Simple0ven
Publisher: Unknown

[ Feep Blocking ] l Unblack ] [ Ask Me Later

Windaws Firewall has blocked this program from aceepting connections from the
Intemet or a network. |f you recognize the program or trust the publisher, you can
unblock it. shen should | unblock a program?

<
a Salution Explorer Running Documents Aukos Locals @ ‘watch | 54 Find Results 1 ﬁ Call Stack. @ Breakpoints Command Window | Bl output

Ready

2. If a Windows Security Alert appears, click
Unblock.

3. Skip ahead to PROCEDURE: Use Eclipse to Launch
the Spotlight Debugger.
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PROCEDURE: Run Java SimpleOven from the Eclipse JDT
If you built C++, please skip this procedure.
1. Go to the Debug button and select 1 QuickStart.

t5 - O v din - Qe -

1 Quickstart

Cebug As »

ﬁ: Cebug. ..

Organize Favarites. ..

PROCEDURE: Use Eclipse to Launch the Spotlight Debugger

1. If a PathMATE menu does not appear on the top
menu bar, open the Customize Perspective...
option in the Window menu. Select the
Commands tab and check the PathMATE
command group on the Commands tab:

& Customize Perspective - Modeling

Shartouts | Commands |

Select the command groups that vou want ko see added to the current perspective (Maodeling), The details field identifies which menu items
andfor koolbar ikems are added to the perspective by the selected command group.

Available command groups: Menubar details: Toolbar details:

keyboard Sharteuts A = B pathMaTE = = I PathMATE toolbar

[] Launch n Launch Spotlight n Launch Spotlight model debugger
License

I:‘ Logging views

Madeling

Madeling

Maodeling Search

Madel Publishing

Open Files

Pluglets

Process

[ Profile

] Profiling Execution views

[ Profiling Object References view
[ Profiling wiews

[ Prowey Tools

[] RequisitePro Upgrade. ..

I:‘ Resource Mavigation L

Use FZ to display the description for a selected command item,

@ [0]'4 l [ Cancel

2. Click OK.

3. To launch Spotlight, pick PathMATE - Launch
Spotlight or choose the Eclipse toolbar Launch

Spotlight button o .
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PROCEDURE: Connect Spotlight to the Running SimpleOven
Program

1. Once Spotlight starts, click the Connect button

| at the left end of the Spotlight toolbar to
connect Spotlight to the target application.

2. Check to see that Spotlight is successfully
connected. The three domains in SimpleOven
appear in the browser on the left, and the status
bar indicates System: Connected.

3. Expand the domains:

& Pathfinder Solutions - PathMATE Spotlight - [Task : SimpleOven/SYS_TASK_ID_MAIN] =3
! File Wiew Execution Tools Window Help x

Q2% dE 0 e/ &% &l ElEE=
|E]| g Q System: Conmected ;l

4 Simple0ven/SYS_TASK_ID_MAIN !
EI E stemalleviceControl

#-EH Oven
= B9 5w
“- fx Operations

Connected tac127.0.0.1, port: 5150
Log
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PROCEDURE: Use Spotlight to Initialize the SimpleOven System

1. Locate the Incident Step button ||

& Pathfinder Solutions - PathMATE Spotlight - [Task : SimpleOven/SYS_TASK_ID_MAIN] =1
! File Wiew Execution Tools  Windms  Help -8 x

R E[d.n e® 8% @l ElF=
g System: Conmected ;I

e E
( )Details

" fx Dperations

Connected to:127.0.0.1, port; 5150
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2. Click the Incident Step button || The status

indicator changes from Connected to Object
Transition.

L Pathfinder Solutions - PathMATE Spotlight - [Task : SimpleOven/SYS_TASK_ID_MAIN] M=
! File Wiew Execukion Tools  Mindow  Help x

Q|2 5d olel@ 8w e ElE=E
|E]| ||¥| ) srealpoint: Object Transition |

4 Simple0ven/SYS_TASK_ID_tAIN
E| EuternalDeviceControl

#-B5 Door
- =B Light
% Owen
=3 Sw

fx Operations

Door:ls0pen Ta Daoor)
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PROCEDURE: Use Spotlight to Browse the Door Class

1. Select the Door class in the browser.

The details pane shows one instance of the Door class. The door object
is in the Open state, and it is part of one oven (association Al).

& Pathfinder Solutions - PathMATE Spotlight - [Task : SimpleOven/SYS_TASK_ID_MAIN] =13
! File Wiew Execution Tools  Windms  Help »

Q2 sd 0lel® 8w 9l ElE=
FIEF PR ® s e st -]

_.; Simple0wven/SvS_TASK_ID_MAIN
E| E EutermalDeviceContral

- fx Operations

E| E MicrowaveCooking 8]
S fx Dpelatlons ~

SEm

| State | A1 is_part_of 1 Oven
Door] Open  [DoubleClick]

fx Operatiohs

Doarls0pen Ta Door)

2

2. Click the Incident Step button || to cause the
Domain Initialization action to be executed and
first Event to be processed.

3. Expand the Door class in the browser and review
the run-time state of this class. Note the Door is in
the Open State. Recall that the only transition out
of the initial state is to the Closed state. To see
why is the Door in the Open State, review the
domain initialization action in the model under
< <Housekeeping>> Domain Support for

<<Domain>>MicrowaveCooking in the Project
Explorer.
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& Pathfinder Solutions - PathMATE Spotlight - [Task : SimpleOven/SYS_TASK_ID_MAIN]

[N File view Execution Tools Window Help
Qa%d ne& 8w ol ElE=

|E]| % gBmakpuci.nt: Object Transition ;l
B

W& Simple0ven/SYS_TASK_ID_MAIN !
E| EsternalDeviceControl
fx Operations
MicrowaveCooking
ﬁ( Operationg

- Door

- -
<%, Agzociations

IMITIAL
Clozed
Open

“ fx Dperations

Dioor: [z0pen To Door]

2>

B
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4. Select Events in the browser. The details pane
shows the events that you can send to the Door
class.

L Pathfinder Solutions - PathMATE Spotlight - [Task : SimpleOven/SYS_TASK_ID_MAIN] =3
! File Wiew Execution Tools Window Help -0 X

Qs d 0lel& 8% O El=

!I@ .ll%l ) Freakpoint: Object Transition -

& Simple0vensSTS_TASK_ID MalN
E EsternalDevicelontrol

: - e Operations

=- E MicrowaveCooking Event |pa,am3
_fx Dperations

E| E Door

Door:lsClozed
Doorlz0pen

-5 Light
g Owen
-3 sw

fx Operations

Doorls0pen Ta Door)

PROCEDURE: Use Spotlight to step through SimpleOven’s Action

Language
M
1. Click the Action Step button .

MicrowaveCooking_Door_Open.pal appears in the
state window.

2. Open the State Window. The figure below shows
where to click in the lower right to open and close
the action/event window.
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athfinder, Solutions - PathMATE Spotlight - [Task : SimpleOven/SYS_ TASK D MAIN]
! File View Execution Tools ‘Window Help

&M 0 ol® &% ol ElE=
E] @I"_ﬁ] ?q g Incident Rction Step LI

& SimpleOven/STS_TASK | 2
B 3 ExtermalDeviceCont |Deta|ls
fx Operations

MicrowaveCooking

Ewvent | Pararns

DoorlsClazed
Daarlz0pen

<) ST 3

=]
Action Step éj
C:/Documents and Settings/tomh/1EM frationalsdp?. 0/work space/QuickStart/cppdgo/PAL_for_debug/MicrowaveCooking_Door_Open EMTRY.pal:1 -
]
v

3. Select the Action Language view. The figure
below shows how to toggle between action
language and the event queue.
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& Pathfinder Solutions - PathMATE Spotlight - [Task : SimpleOven/SYS_TASK_ID_MAIN]

! File Wiew Execution Tools ‘Window Help

Q|2 5 0lel& &% ol EIE=
FEP I -]

& SimpleOven/SYS_Task |2 2
EI E3 EsternalDeviceCont |Dela|ls

fx Operations
= E MicrowaveCooking Evert | Params
- fx Operations
- E Door

<, Agzociations

DoorlsCloged
Doorlz0pen

- Events Click Here

#-BF Oven

BB Sw EventName | Params | Source | Destination

< | | 3
]
Actioh Step ~
C:/Documents and SettingstombABM Arationaledp?. 0/work space/ Quick Start/ cppdgo/PaL_for_debug/MicrowaveCocking_Door_Open_EMTRY . pall
|
i

4. Click Action Step again . The active step
arrow advances to the next PAL statement.

& Pathfinder Solutions - PathMATE Spotlight - [Task : SimpleOven/SYS_TASK_ID_MAIN]

ile  Wiew Execution Tools Window Help

olol® ¥ ol ElE=
00| [® i v

MicrowaveCooking
ﬁ( Operations

_ID | State | AT: is_part_of 1 Oven
Doorl) Open  [DoubleClick)

C:/Docurments and Settingstomh/1BM frationalsdp?. 0/work space/DuickStart/oppfac/PAL_for_debug/MicrowaveCooking_Door_Open_ENTRY.pal
RefcLight > interior_light = FIND this-»&1-242;
= GEMERATE Light: TurnOn (] TO [interior_light ];

]| | B
B
|
C:/Documents and S ettingz/tomh/BM frationalsdp?. 0/ workspace/Quick Start/cppdge/PAL_for_debug/MicrowaveCooking Door_Open_ENTRY pal:2 -
™
< ] | 2
A
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5. Continue to click the Action Step button @
until MicrowaveCooking_Light_On_entry.pal
appears in the PAL viewer.

(DO NOT CLICK AGAIN. If you do, you will queue up an action.
Incident Action Step will change to Action Step Pending and the Red
stoplight will change to Green. If this happens, all is not lost, but the
Event Processing in the next procedure will proceed immediately on
the event hitting the queue.)

PROCEDURE: Use Spotlight to Send Event (Signal) to SimpleOven

1. Select Door in the browser. Right-click the Door()
field in the details pane to bring up a context-
sensitive menu:

& Pathfinder Solutions - PathMATE Spotlight - [Task : SimpleOven/SYS_TASK_ID_MAIN] =3
u Fila Wiew Execution Tools Window Help - 8 X

wasE ood v ol EFE=
(3]0 6] 098] [ rocssene metson oo

1 B a
<& Simple0ven/SYS_TASK, Dotails

—-£9 ExtemalDeviceContre
Jx Opersons | [ WirowaveCooking Dosimsanees
=13 MicrowaveCooking _ID | State | A1:is_part_of 1 Oven
ﬁ( Operations » Do) Neen_iFioobleCick )
+- Door Update Door(), .
+-F Light Delete Door() instance

- Oven
+-F3 5w

= Generate event For Door()... =
C:/Documents set Breakpoints. . | workspace/QuickStart/cpp/ge/PAL_for_debug/MicrowaveCooking_Light_On_EMNTRY.pal
= Externalllel  animate Instance EVICE_LIGHT :

Animate Exclusivel

L5

|»

Action Step
C:/Documents and 5ettingstomh/|BM fratiohalsdp?. DAworkspace/ QuickStart/cppdge/Pal_for_debug/MicrowaveCooking_Light_On_ENTRY.pal1

|10 || =

< | 2
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2. Select Generate event for Door() in the pop-up
menu. The Send Event dialog opens. Select
Door:IsClosed in the drop-down list.

& Send Event

Select event to zend:

Mo arguments. Presz Send to continue,

| Send I Help Cancel

3. Click Send.

4. Toggle from the Action Language viewer to the
event queue in the lower pane. The event
Door:IsClosed re queued to be sent to Door(). The
event appears in the queue under Events in the
lower pane.

& Pathfinder Solutions - PathMATE Spotlight - [Task : SimpleOven/SYS_TASK_ID_MAIN]
! Fila Wiew Execution Tools Window Help

R2/s6(d o/o/&) olepl ElEE=
Q0] AR [® o e

o SimpleOven/SYS_TASK, IT) o
EE ExtemnalD eviceContr Etal

b ﬁ( Operations
5 MiCTUWﬁVE_EUUkinQ _ID ‘ State |A1' iz_part_of 1 Oven
Jx Operations Dool) Open [DoubleClick]
H Door
H Light
; H oven
BET Sw
Eventhame | Params | Source| Destination
Droor:lsClosed Doorl)
< 1] ] >
=]
Action Step ~
C:/Documents and Settings/tomh/IBM frationalsdp?. 0/workspace/QuickStat/cpp/ge/PAL_for_debug/MicrowaveCooking_Light_On_EMTRY . pal:1 e
v
< | | 2 B
A
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>

5. Press the Spotlight Go button == to resume
execution, and allow SimpleOven to process the
new event.

6. You may choose to continue execution by
resending Door:IsOpen and Door:IsClosed events.
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Generate System Documentation

PROCEDURE: Generate Documentation
Return to PathMATE and transform:

1. Select the All Reports deployment:
2. Select Transform.

From the resource perspective explore the generated reports in the
reports folder. ( Note: a benign warning “Properties file properties.txt
not found.” will be written to the Eclipse Console View.)

[ *project Explarer 52 ER-aa =i 1 - vodelpathmate X [Z] properties.bxt (@ Assaciation repart For MicrowaveCooking ... =0
= = QuickStart PathMATE Deployment
- (2 Diagrams . e
= (2 models PIM: platfarm: fresource/QuickStart{QuickSkart System Madel. emix Mame: All Reports
== pp . | &l Repart Wworking Dir: PROJECT_DIR,
.@ CuickStart: System Model, pathmate Deploymer: ke ad erking bir =
=& reports &8 Single Process C V] Resolved location: C:jDocuments a
4= al_eref &8 Single Process Java Transformation: Default Report:
- asci_dump
#-[= ExtractedDiagrams 4E export actions v
#-[= paL_for_debug == Fa
=] completeness.txt < S
|=] consiskency . kxk E = =
|5 simpleCrven_ExternalDeviceControl_trimming_results kxt Froperties | Tasks | 5] Console £2 . Bookmarks | Action Language | Search n o | ™ 15 =]
SimpleCrven_MicrowaveCooking_summary . rtF PathMATE Consale
=l simpleCven_MicrowaveCooking_trimming_results.bxt ~
SimpleCven_MicrowaveCooking.rtf
SimpleCrven_statistics,csy
SimpleCrven_summary.rtf
SimpleCren.rtf PathMATE Transformation Engine - Tue Apr 03 11:23:04 GMT-05:00 2007
4] =% ReferenceSimpleOven
Properties file properties.txt not found.
= = b’
o= Outline &3 Inheritance Explorer 8 < >
Generated documentation files:
Report Title Filename
Domain Report for SimpleOven | SimpleOven_summary.rtf
Full Analysis Report for SimpleOven.rtf
SimpleOven
Class Modeling Report for SimpleOven_MicrowaveCooking_summary.rtf
SimpleOven.MicrowaveCooking
State Modeling report for SimpleOven_MicrowaveCooking.rtf
SimpleOven.MicrowaveCooking

3. To view any of the generated files, right-click on
the file in the Project Explorer and select Open
With > System Editor.
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Congratulations!
You have documentation and reports for your
QuickStart system.

You have now completed the Quick Start.
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Summary

PathMATE separates the feature logic of a system from the details of
its implementation on a specific platform. That separation yields
simplicity, facilitating the solution of each aspect of the system in
relative isolation from the others. The simplicity of platform
independent models yields substantial benefits all across the
development cycle. With PathMATE you will:

e Improve productivity in your initial development effort.
React quickly to changing software and hardware requirements.

Test integration of all system components at the model level,
much earlier in the development cycle.

Substantially reduce the time required for debugging.
Improve reliability and performance.
e Consistently meet your deadlines.

Additionally, the use of platform-independent action language gives
PathMATE a complete semantic awareness of everything that your
system will do, allowing it to do Self Optimization of your system as it
generates your implementation code. This yields substantial
performance gains over code generated from code-in-the-model
approaches.

Pathfinder’s tools help you transform your models into executable
code, predictably and accurately. Deploy faster, highly reliable
embedded systems much more quickly than you thought possible.

Next Steps

The white papers at www.pathfindermda.com contain additional
information. Most importantly, try the PathMATE toolset with real code,
as outlined in this Guide. We can help you get started.

Pathfinder Solutions

Headquartered in Foxboro, Massachusetts, Pathfinder Solutions
provides embedded software engineers with the tools, methods and
services needed to boost developer productivity and improve quality.
Pathfinder Solutions is Platform Member of the Object Management
Group (OMG).

If you would like to learn more, please contact us at:

Pathfinder Solutions

33 Commercial Street, Suite 2
Foxboro, MA 02035 USA

Phone: 888-662-7284

Email: info@pathfindermda.com
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Acronyms

Acronym Definition

JDT Java Developer Toolkit

MDA Model Driven Architecture

MDD Model Driven Development

OMG Object Management Group

PAL Platform-independent Action Language

PathMATE Pathfinder Model Automation and
Transformation Environment

PIM Platform Independent Model

UML Unified Modeling Language
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